Problem with simple MVVM ToolKit

Sep 7, 2012 at 4:15 PM
Edited Sep 7, 2012 at 4:21 PM

hi.

i recently came across your project, and i've been trying to get my head wrapped around on the framework. so far it looks really simple to work with and great for my needs.

so on to my problem, every time i start a debug session, or i run my app visual studio goes into disassembly mode. sometimes it will open a dialog window looking for MessageBusProxy.cs, sometimes looking for another file.

 what's the problem, and how can i fix this? 

 

i've noticed that this behaviour happens every single time the code reaches my serviceagent class.

help would be appreciated

thanks in advance

 

forgot to add this:

Call stack location:

SimpleMvvmToolkit-WPF.dll!SimpleMvvmToolkit.ModelBase<TestApp.Models.TestValueObject>.ModelBase() line 25

Visual Studio Source File Information:

Locating source for 'C:\Projects\SimpleMvvmToolkit\Download\SimpleMvvmToolkit\Source\WPF\SimpleMvvmToolkit-WPF\ModelBase.cs'. Checksum: MD5 {f3 27 49 4 1d e4 eb 47 22 a3 e7 2b a5 3 23 5a}The file 'C:\Projects\SimpleMvvmToolkit\Download\SimpleMvvmToolkit\Source\WPF\SimpleMvvmToolkit-WPF\ModelBase.cs' does not exist.Looking in script documents for 'C:\Projects\SimpleMvvmToolkit\Download\SimpleMvvmToolkit\Source\WPF\SimpleMvvmToolkit-WPF\ModelBase.cs'...Looking in the projects for 'C:\Projects\SimpleMvvmToolkit\Download\SimpleMvvmToolkit\Source\WPF\SimpleMvvmToolkit-WPF\ModelBase.cs'.The file was not found in a project.Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\crt\src\'...The debug source files settings for the active solution indicate that the debugger will not ask the user to find the file: C:\Projects\SimpleMvvmToolkit\Download\SimpleMvvmToolkit\Source\WPF\SimpleMvvmToolkit-WPF\ModelBase.cs.The debugger could not locate the source file 'C:\Projects\SimpleMvvmToolkit\Download\SimpleMvvmToolkit\Source\WPF\SimpleMvvmToolkit-WPF\ModelBase.cs'.

Sep 10, 2012 at 3:59 PM
Edited Sep 10, 2012 at 4:04 PM

anyone?

i've been at it for the past 4 days...and i found out that this only happens when i'm debugging. any ideas on how to solve this issue? i would like to debug my application without this issue.

help would be appreciated

Coordinator
Sep 10, 2012 at 9:16 PM

I think you probably just have to uncheck the Visual Studio option, "Show disassembly when source is not available": http://msdn.microsoft.com/en-us/library/85yzd16c.aspx.

Cheers,

Tony

Sep 11, 2012 at 7:15 PM

done that...that was one of the first things i tried and still it gives me the same problem while debugging my app.

i though it could be the pre-requisites, ran through the list and i have them.

the only thing different is that i'm running visual studio on a 64 bit machine.

 

help would be appreciated.

thanks