AppPlatformVersion

Nov 20, 2011 at 2:03 PM

Hi,

I'm starting to learn Windows Phone 7 Development. I want to use the MVVM pattern in my application and I came across this toolkit.

When I use the simpleMVVM project template to create a Windows Phone 7 application the AppPlatformVersion in the manifest file defaults to 7.0.

  • Isn't the simpleMVVM toolkit 2.1 version compatible yet with the Windows Phone 7.1 SDK?
  • Is it possible to reference the simpleMVVM assemblies in a 7.1 version? 
  • Is there a big difference between the 7.0 and 7.1 SDK? Do I have to use the 7.1 SDK if I want to create an app that is suitable for the 7.5 Mango version?
Coordinator
Nov 21, 2011 at 11:55 AM

Now that Windows Phone 7.1 SDK has made it out of beta, I plan to upgrade the Simple MVVM Toolkit to be compatible with it.  However, if you can't wait for that, there is a fix, which is described here: http://simplemvvmtoolkit.codeplex.com/workitem/342.  I'll be sure to test it for compatibility with 7.5 Mango as well.  Something for me to do this next weekend. ;-)

Cheers,

Tony