Simple MVVM 4.0.0.0 requires .NET 4.5?

Jul 24, 2013 at 8:38 PM
Edited Jul 24, 2013 at 8:42 PM
I've been considering the use of Simple MVVM 4.0.0.0 in a new WPF-based app I'm starting. I've installed the toolkit and played with some of the samples. So far, I like what I see.

However, I noticed that the ReadMe.txt file supplied with the installation notes that "this version supports only WPF 4.5". In my case, I need to target .NET 4.0 as the application still needs to be compatible with Windows XP (which is not supported by .NET 4.5).

On the surface, that would seem to preclude the use of version 4.0.0.0 in my app (though I guess I could use the older 3.1.0.0 version). However, I've noticed (somewhere on your site), a mention of ".NET framework 4.5 (required for installer)" comment, which made me wonder if the 4.5 requirement was not a requirement of the toolkit itself, but only of the installation program?

A little experimentation seems to indicate that version 4.0.0.0 does indeed require the application to target .NET 4.5, as it won't build when targeting .NET 4.0.

So, the questions:
  • Is .NET 4.5 required by the v4.0.0.0 toolkit itself? (I think so).
  • What do I lose by moving back to v3.1.0.0? Is that even a good idea, or is 3.1.0.0 at end of life?
Thanks for your input.

Jeff Godfrey
Jul 24, 2013 at 9:37 PM
Version 4.0 of the toolkit does depend on .NET 4.5. But version 3.0 supports .NET 4.0 and is functionally equivalent to v4. And it will continue to be supported along side v4 for developers using .NET 4.0 on VS 2010.
Jul 24, 2013 at 10:15 PM
Tony,

I'm glad to hear that V3 is still supported and functionally equivalent to v4. I'll get it installed and give it a closer look. Thanks for the speedy reply.

Jeff
Jul 24, 2013 at 10:39 PM
Tony,

My next issue... I'm using VS 2012. Is it possible to install v 3.x into VS 2012? The installer completes successfully, but mentions that it's installing for VS 2010 (which I don't even have). Once that's complete, I don't see any related project templates in VS 2012.

Thanks,

Jeff
Jul 24, 2013 at 11:53 PM
I see ... v3 of the toolkit targets VS 2010. If you don't want to install VS 2010, you can install both v3 and v4. Then when you create a WPF project, target .NET 4, and then replace the v4 toolkit references with a v3 reference. Wish it were easier, but most people developing .NET 4 apps would be using VS 2010. ;)
Jul 25, 2013 at 12:40 AM
Edited Jul 25, 2013 at 2:02 AM
Understood. That'll work - thanks.

*** Edit - Just a follow up. You're above-mentioned method of using v3 in VS 2012 seems to have worked just fine. Thanks! ***