Error 1937. An error occured during the installation of assembly 'Microsoft.Build, Version="4.0.0.0"

Nov 17, 2012 at 6:24 AM
Edited Nov 17, 2012 at 8:40 PM

Trying to install 3.1.0.0 (17.2 MB (18,047,742 bytes)) downloaded today (2012/11/16) on Windows 7 x64/VS 2010 and keep getting the error from the subject...

Anyone else experienced this problem?

BTW, 3.0.0.0 installs fine and prerequisits are the same so I don't think it's related to that...

EDIT: Not sure how this makes any sense but after installing the .NET Framework 4.5 I was able to install 3.1...

Coordinator
Dec 14, 2012 at 1:24 PM
Edited Dec 22, 2012 at 11:42 AM

The installer for v4 / VS 2012 has some problems.  I used InstallShield to create it, but it seems to drag in some unwanted dependencies.  I plan to look at it in the next week or so to try to remove those dependencies.  Thanks for your patience.

EDIT: Hope to work on the installer over the holidays, when I'll have more time.  Sorry about all the headaches.  Wish I had used WIX instead of InstallShield ... I had no idea it would cause problems.

Feb 26, 2013 at 7:07 PM
tonysneed wrote:
The installer for v4 / VS 2012 has some problems.  I used InstallShield to create it, but it seems to drag in some unwanted dependencies.  I plan to look at it in the next week or so to try to remove those dependencies.  Thanks for your patience. EDIT: Hope to work on the installer over the holidays, when I'll have more time.  Sorry about all the headaches.  Wish I had used WIX instead of InstallShield ... I had no idea it would cause problems.
Has this be fixed I get this same problem with windows 7 64bit and I cannot use V4 as I am programming against wp7.
Coordinator
Feb 26, 2013 at 7:14 PM
Edited Feb 26, 2013 at 7:45 PM
Make sure to install .NET Framework 4.5. This should address the issue. A new installer has been released which corrects other errors: http://simplemvvmtoolkit.codeplex.com/releases/view/96535