CLS Compliant Issue

Nov 5, 2012 at 4:58 AM

Hi Tony,

I upgraded the project to VS 2012 and installed the toolkit from Extension Manager.

I have reference to SimpleMvvmToolkit-SL5 and SimpleMvvmToolkit-Common.

The project runs fine but is warning liket:

"MyViewModel.cs: base type SimpleMvvmToolkit.ViewModelBase<MyViewModel> is not CLS-compliant"

Any suggestions?

Coordinator
Nov 5, 2012 at 3:18 PM
There's an assembly attribute that has to go into the AssemblyInfo.cs file for the v4 projects:

[assembly: CLSCompliant(true)]

I'll get this into the next patch. In the meantime, you can put it in there yourself.

Cheers,
Tony
Coordinator
Nov 6, 2012 at 12:31 AM
You can download and run the installer for v4 again. It's now CLS Compliant.
Nov 6, 2012 at 1:59 AM

Thanks for the update! Works fine now.