Are SL4 Tools included in VS2010 SP1 ?

Aug 20, 2012 at 3:42 PM

The prereqs for Simple MVVM 3.0 lists VS2010 SP1, and also SL 4 Tools.

But attempting to install SL4 after SP1 gives error:

Visual Studio 2010 or Visual Web Developer Express 2010 or Visual Phone Developer Express 2010 that matches the language version of Silverlight Tools 4 must be installed before installation of Silverlight Tools can continue. 

And various posts I've found seem to indicate that VS2010 SP1 already includes SL 4 tools., but the SL4 installer gets confused when SP1 has already been installed. 

So do I really need to install SL4 tools? And if so, how?

DC

Coordinator
Sep 10, 2012 at 10:26 PM

What happens if you just skip installing the SL4 Tools?  Are you able to create SL4 projects?

Tony