Test project not being created

Oct 17, 2011 at 5:46 PM

I downloaded and installed the Simple MVVM toolkit and created my first Ria Services project.

The following message came up "A problem was encountered creating the sub project 'SimpleMVVMRiaServices3.Test', c:\Users\...\AppData\Local\Temp\ndcxahxb.hlx\Temp\SimpleMvvmRiaServices3.Test.csproj(121,3): The imported project C:\Users\...\AppData\Local\Temp\ndcxahxb.hlx\Temp\Microsoft.Silverlight.Toolkit.Build.targets" was not found. Confirm that the path in the <Import> declaration is correct and that the file exists on disk.

The test project was not created.

Any known solutions?

 

Oct 17, 2011 at 9:08 PM
Make sure you've installed all the prerequisites, including the Silverlight Toolkit, which has the testing framework.

Cheers,
Tony
Oct 18, 2011 at 8:54 PM
Edited Oct 18, 2011 at 9:57 PM

Thanks for the reply Tony.  I reinstalled the Sliverlight Toolkit and got through the first screencast.  Now, after creating the test as you did in the screencast and setting the test project as the default project I press the run button and get a 4004 IsolatedStorageException: Operation not permitted.

Sorry to be a bother, but I am urgently trying to discover if your toolkit is the one we should choose for our project.

Also, I checked on the Application Storage table and "Enabled" is checked.

Its weird.  I don't see anywhere in the application where it is using isolated storage.

 

Oct 19, 2011 at 12:16 AM

GLanPh, Check out this link http://forums.silverlight.net/p/181927/412431.aspx

I realize you say the App Storage Tab has been checked but Tim Heuer makes mention of a bat file that could be disabling this within the isolated storage directory

 

-cheers

rlcrews

 

Oct 19, 2011 at 1:29 AM

Thanks rlcrews,

I saw Tim's post before I posted here.  That file does not exist on my drive.  The test project works on my computer at home, just not on the one that matters.

Oct 19, 2011 at 12:33 PM

It looks like the Silverlight Testing Framework (part of the Silverlight Toolkit) uses isolated storage to save stuff.  That exception could mean a number of things, for example, a security problem or lack of space. Are you working in a restricted security environment? Have you tried running Visual Studio as Administrator?

Oct 19, 2011 at 4:00 PM

Tony, you are exactly correct.  Somehow my Visual Studio "run as administrator" got unchecked. It works now.  Thanks again.

Feb 16, 2012 at 4:21 PM

Hello. I am experiencing the same problem. I have the following installed:

VS 2010 SP 1 installed

.Net FW 4

Silverlight 5

Silverlight 5 tools

Silverlight toolkit 5 (december 2011)

Simple Silverlight toolkit

Despite all this, I'm getting the above error. Any ideas?

 

Russ

Feb 16, 2012 at 4:28 PM
I'm planning to upgrade the toolkit to support SL 5 next week. For now try the SL prerequisites.